Quantcast

FreeBSD Port: x11-drivers/xf86-video-intel

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FreeBSD Port: x11-drivers/xf86-video-intel

John Stokes-2
Hi guys

Any chance of seeing the latest Intel 2.4.0 drivers ported across to
FreeBSD -it finally supports the G35 chipset that my motherboard
uses.Yes I know they have only been released last Wednesday ;-)     but
I am prepared to wait so I can finally get my motherboard working (only
VESA at present).

Regards

John
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FreeBSD Port: x11-drivers/xf86-video-intel

Sam Fourman Jr.
> Any chance of seeing the latest Intel 2.4.0 drivers ported across to FreeBSD
> -it finally supports the G35 chipset that my motherboard uses.Yes I know
> they have only been released last Wednesday ;-)     but I am prepared to
> wait so I can finally get my motherboard working (only VESA at present).
>

For what it is worth, I also have 3 computers using VESA at the moment
that use G35.

Sam Fourman Jr.
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FreeBSD Port: x11-drivers/xf86-video-intel

Florent Thoumie
In reply to this post by John Stokes-2
On Tue, Jul 29, 2008 at 12:20 PM, John Stokes <[hidden email]> wrote:
> Hi guys
>
> Any chance of seeing the latest Intel 2.4.0 drivers ported across to FreeBSD
> -it finally supports the G35 chipset that my motherboard uses.Yes I know
> they have only been released last Wednesday ;-)     but I am prepared to
> wait so I can finally get my motherboard working (only VESA at present).

I'll happily commit it if you can test it.

Just bump PORTVERSION to 2.4.0, run `make makesum` and `make all install clean`.

--
Florent Thoumie
[hidden email]
FreeBSD Committer
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FreeBSD Port: x11-drivers/xf86-video-intel

Christian Laursen-2
"Florent Thoumie" <[hidden email]> writes:

> On Tue, Jul 29, 2008 at 12:20 PM, John Stokes <[hidden email]> wrote:
>> Hi guys
>>
>> Any chance of seeing the latest Intel 2.4.0 drivers ported across to FreeBSD
>> -it finally supports the G35 chipset that my motherboard uses.Yes I know
>> they have only been released last Wednesday ;-)     but I am prepared to
>> wait so I can finally get my motherboard working (only VESA at present).
>
> I'll happily commit it if you can test it.
>
> Just bump PORTVERSION to 2.4.0, run `make makesum` and `make all install clean`.

I just tested it on two laptops here and it works fine on both of them.

One of them has a 915GM chipset and the other one has a 965GM.

I have had to run with the NoAccel option turned on for a while but
that is now no longer neccesary. Very nice.

--
Christian Laursen
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FreeBSD Port: x11-drivers/xf86-video-intel

Jimmie James
In reply to this post by John Stokes-2
> >> Any chance of seeing the latest Intel 2.4.0 drivers ported across to
FreeBSD
>>> -it finally supports the G35 chipset that my motherboard uses.Yes I know
>>> they have only been released last Wednesday ;-)     but I am prepared to
>>> wait so I can finally get my motherboard working (only VESA at present).

>> I'll happily commit it if you can test it.
>>
>> Just bump PORTVERSION to 2.4.0, run `make makesum` and `make all install clean`.

>I just tested it on two laptops here and it works fine on both of them.

>One of them has a 915GM chipset and the other one has a 965GM.

>I have had to run with the NoAccel option turned on for a while but
>that is now no longer neccesary. Very nice.

Quick question for you Christian, you were running with NoAccel, were
you getting this error with it?

Error in I830WaitLpRing(), timeout for 2 seconds
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0x13e1ad64) and PRB0_TAIL (0x0001afa8)
indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.

I'd love if this new version has fixed this problem.


--
Over the years I've come to regard you as people I've met.
O< ascii ribbon campaign - stop html mail - www.asciiribbon.org
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FreeBSD Port: x11-drivers/xf86-video-intel

Christian Laursen-2
Jimmie James <[hidden email]> writes:

>> >> Any chance of seeing the latest Intel 2.4.0 drivers ported across
>> to
> FreeBSD
>>>> -it finally supports the G35 chipset that my motherboard uses.Yes I know
>>>> they have only been released last Wednesday ;-)     but I am prepared to
>>>> wait so I can finally get my motherboard working (only VESA at present).
>
>>> I'll happily commit it if you can test it.
>>>
>>> Just bump PORTVERSION to 2.4.0, run `make makesum` and `make all install clean`.
>
>>I just tested it on two laptops here and it works fine on both of them.
>
>>One of them has a 915GM chipset and the other one has a 965GM.
>
>>I have had to run with the NoAccel option turned on for a while but
>>that is now no longer neccesary. Very nice.
>
> Quick question for you Christian, you were running with NoAccel, were
> you getting this error with it?
>
> Error in I830WaitLpRing(), timeout for 2 seconds
> (WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
> (WW) intel(0): PRB0_HEAD (0x13e1ad64) and PRB0_TAIL (0x0001afa8)
> indicate ring buffer not flushed
> (WW) intel(0): Existing errors found in hardware state.

I don't remember getting it. I have only saved one Xorg log file from
the old driver and that error is not in there.

It might have been there on the other laptop though...

--
Christian Laursen
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Loading...