Quantcast

Xorg - Server is already active for display 0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Xorg - Server is already active for display 0

Rajen Jani (BT Yahoo! Broadband)

   Hello Everyone,
            I ran Xorg after a successful make install clean session. I
   ran the xfgconfig command and done the all the configuration.
   When I try to run Xorg now it gives me the error above. Below is a
   short history of what I have done. Any help will be great.
   Regards,
   Rajen
   P.S. When I check the var log it only shows me the same error.
   ritm# Xorg
   Fatal server error:
   Server is already active for display 0
           If this server is no longer running, remove /tmp/.X0-lock
           and start again.
   Please consult the The X.Org Foundation support
            at [1]http://wiki.X.Org
    for help.
   ritm# rm -rf /tmp/.X0-lock
   ritm# Xorg
   _XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
   _XSERVTransMakeAllCOTSServerListeners: server already running
   Fatal server error:
   Cannot establish any listening sockets - Make sure an X server isn't
   already running
   Please consult the The X.Org Foundation support
            at [2]http://wiki.X.Org
    for help.
   Please also check the log file at "/var/log/Xorg.0.log" for additional
   information.

References

   1. http://wiki.X.Org/
   2. http://wiki.X.Org/
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xorg - Server is already active for display 0

Norbert Papke
On Tue, 2007-27-02 at 14:55 +0000, Rajen Jani (BT Yahoo! Broadband)
wrote:
>           I ran Xorg after a successful make install clean session. I
>    ran the xfgconfig command and done the all the configuration.
>    When I try to run Xorg now it gives me the error above. Below is a
>    short history of what I have done. Any help will be great.
>    Regards,
>    Rajen
>    P.S. When I check the var log it only shows me the same error.
>    ritm# Xorg
>    Fatal server error:

A few suggestions:

* Ensure that you don't have a login manager such as gdm, kdm, wdm, or
xdm running.  They will start the X server.
* make sure you kill any existing X server.  "killall -9 Xorg"
* start the X server using the "startx" command rather than Xorg
* Look in the /var/log/Xorg.0.log file for error messages

Cheers,

-- Norbert.


_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-x11
To unsubscribe, send any mail to "[hidden email]"
Loading...