Quantcast

error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Siju George
Hi,

How do i fix this error?
====================================
freebsdsrv# pwd
/usr/ports/emulators/linux_base-fc6
freebsdsrv# make install clean
===>  linux_base-fc6-6_5 linuxulator is not (kld)loaded.
*** Error code 1

Stop in /usr/ports/emulators/linux_base-fc6.
freebsdsrv#
=====================================

Thanks

--Siju
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Siju George
On Sat, Mar 29, 2008 at 4:43 AM, Siju George <[hidden email]> wrote:

> Hi,
>
>  How do i fix this error?
>  ====================================
>  freebsdsrv# pwd
>  /usr/ports/emulators/linux_base-fc6
>  freebsdsrv# make install clean
>  ===>  linux_base-fc6-6_5 linuxulator is not (kld)loaded.
>  *** Error code 1
>
>  Stop in /usr/ports/emulators/linux_base-fc6.
>  freebsdsrv#
>  =====================================
>
>  Thanks
>
>  --Siju
>

I did

#kldload linux

and now get this error

========================================
freebsdsrv# pwd
/usr/ports/emulators/linux_base-fc6
freebsdsrv# make install clean
===>  linux_base-fc6-6_5 compat.linux.osrelease: 2.4.2 is not supported.
*** Error code 1

Stop in /usr/ports/emulators/linux_base-fc6.
freebsdsrv#
==============================================

How do I fix this?

thanks

Siju
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Beech Rintoul-5
On Friday 28 March 2008, Siju George said:
> On Sat, Mar 29, 2008 at 4:43 AM, Siju George <[hidden email]>
wrote:

> > Hi,
> >
> >  How do i fix this error?
> >  ====================================
> >  freebsdsrv# pwd
> >  /usr/ports/emulators/linux_base-fc6
> >  freebsdsrv# make install clean
> >  ===>  linux_base-fc6-6_5 linuxulator is not (kld)loaded.
> >  *** Error code 1
> >
> >  Stop in /usr/ports/emulators/linux_base-fc6.
> >  freebsdsrv#
> >  =====================================
> >
> >  Thanks
> >
> >  --Siju
>
> I did
>
> #kldload linux
>
> and now get this error
>
> ========================================
> freebsdsrv# pwd
> /usr/ports/emulators/linux_base-fc6
> freebsdsrv# make install clean
> ===>  linux_base-fc6-6_5 compat.linux.osrelease: 2.4.2 is not
> supported. *** Error code 1
>
> Stop in /usr/ports/emulators/linux_base-fc6.
> freebsdsrv#
> ==============================================
>
> How do I fix this?

If you had read UPDATING you would see to do:

sysctl compat.linux.osrelease=2.6.16

Add:

compat.linux.osrelease=2.6.16 to /etc/sysctl.conf

Beech

> thanks
>
> Siju


--
---------------------------------------------------------------------------------------
Beech Rintoul - FreeBSD Developer - [hidden email]
/"\   ASCII Ribbon Campaign  | FreeBSD Since 4.x
\ / - NO HTML/RTF in e-mail   | http://www.freebsd.org
 X  - NO Word docs in e-mail | Latest Release:
/ \  - http://www.FreeBSD.org/releases/7.0R/announce.html
---------------------------------------------------------------------------------------



_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Alexander Leidinger
Quoting Beech Rintoul <[hidden email]> (Fri, 28 Mar 2008 17:04:08 -0800):

> On Friday 28 March 2008, Siju George said:
> > On Sat, Mar 29, 2008 at 4:43 AM, Siju George <[hidden email]>
> wrote:
> > > Hi,
> > >
> > >  How do i fix this error?
> > >  ====================================
> > >  freebsdsrv# pwd
> > >  /usr/ports/emulators/linux_base-fc6
> > >  freebsdsrv# make install clean
> > >  ===>  linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Why do you want to install this manually instead of depending on the
default? If you don't have the documented need for this, you should
just install the linux program you need from ports, as it will install
a good linux base for you.

> > How do I fix this?
>
> If you had read UPDATING you would see to do:
>
> sysctl compat.linux.osrelease=2.6.16
>
> Add:
>
> compat.linux.osrelease=2.6.16 to /etc/sysctl.conf

That's only half of the solution, he also needs to override the default
setting in make.conf to not get into dependency trouble. Ideally this
information is also available in UPDATING...

Bye,
Alexander.

--
The algorithm to do that is extremely nasty.  You might want to mug
someone with it.
                -- M. Devine, Computer Science 340
http://www.Leidinger.net  Alexander @ Leidinger.net: PGP ID = B0063FE7
http://www.FreeBSD.org     netchild @ FreeBSD.org  : PGP ID = 72077137
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Boris Samorodov
On Sat, 29 Mar 2008 12:56:15 +0100 Alexander Leidinger wrote:
> Quoting Beech Rintoul <[hidden email]> (Fri, 28 Mar 2008 17:04:08 -0800):

> > If you had read UPDATING you would see to do:
> >
> > sysctl compat.linux.osrelease=2.6.16
> >
> > Add:
> >
> > compat.linux.osrelease=2.6.16 to /etc/sysctl.conf

> That's only half of the solution, he also needs to override the default
> setting in make.conf to not get into dependency trouble. Ideally this
> information is also available in UPDATING...

Alexander, did you mean "this information should be available..."
or "this information is already available..."? I'd say that the latter
is the right one. It is documented at the record "20070327: AFFECTS:
users of emulators/linux_base-fc6".


WBR
--
Boris Samorodov (bsam)
Research Engineer, http://www.ipt.ru Telephone & Internet SP
FreeBSD committer, http://www.FreeBSD.org The Power To Serve
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: error installing linux emulator- linux_base-fc6-6_5 linuxulator is not (kld)loaded.

Alexander Leidinger
Quoting Boris Samorodov <[hidden email]> (Sat, 29 Mar 2008 16:19:02 +0300):

> On Sat, 29 Mar 2008 12:56:15 +0100 Alexander Leidinger wrote:
> > Quoting Beech Rintoul <[hidden email]> (Fri, 28 Mar 2008 17:04:08 -0800):
>
> > > If you had read UPDATING you would see to do:
> > >
> > > sysctl compat.linux.osrelease=2.6.16
> > >
> > > Add:
> > >
> > > compat.linux.osrelease=2.6.16 to /etc/sysctl.conf
>
> > That's only half of the solution, he also needs to override the default
> > setting in make.conf to not get into dependency trouble. Ideally this
> > information is also available in UPDATING...
>
> Alexander, did you mean "this information should be available..."
> or "this information is already available..."? I'd say that the latter
> is the right one. It is documented at the record "20070327: AFFECTS:
> users of emulators/linux_base-fc6".

Something in between. I know that it is documented for fc6. But if the
user looks at other places, it may not be documented (depending on the
age of the ports tree).

Bye,
Alexander.

--
If you do not want to get beeps in X11 (X Windows), you can turn them off with

        xset b off
http://www.Leidinger.net  Alexander @ Leidinger.net: PGP ID = B0063FE7
http://www.FreeBSD.org     netchild @ FreeBSD.org  : PGP ID = 72077137
_______________________________________________
[hidden email] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-ports
To unsubscribe, send any mail to "[hidden email]"
Loading...